PHP is among the most widely used open-source server-side coding languages. It is quite popular as it is free software, which you can use to develop responsive sites like community websites, e-stores or e-teaching websites instead of static HTML-based sites. A PHP module must be available on the server where a PHP-powered website is hosted so that its source code can be read. As there are no license charges for such a module and the language provides infinite options for the Internet applications that you develop, there’re hundreds of millions of PHP websites. On top of that, there are numerous open-source PHP-based scripts, which you can use for your websites without the need to have any coding skills. As there are a handful of versions of PHP, you need to verify that the same version that you used while creating your website is activated on the server too.

PHP 4, PHP 5 and PHP 7 Support in Shared Hosting

If you order a shared hosting package from us, you won’t ever have to think about whether your sites are compatible with the web hosting environment, since we offer support for multiple versions of PHP for the sake of your convenience. The Hepsia hosting Control Panel will permit you to pick PHP 4, PHP 5 and PHP 7 with just one click and if you want to change the current version, the update will take effect immediately. Thus, years of work on sites created with an older version won’t be wasted. Our hosting platform will even permit you to use a different version of PHP for each domain hosted in your account, which suggests that you can use newer and older scripts simultaneously. Most hosting providers on the market support one, sometimes two versions of PHP. Unlike them, we consider that you should be the one to select the version that will be used by your own sites.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

Our Linux semi-dedicated services support multiple PHP versions, which means that you’ll be able to run all the web-based applications that you have created through the years. The Hepsia Control Panel, which comes bundled with each semi-dedicated account, will enable you to activate the version that you need with one single click. You can select between PHP 4, PHP 5 and PHP 7. In case you would like to host multiple sites under one and the same account and they have special requirements in relation to the hosting environment, you’ll be able to set a different version for each one of them no matter which version is selected for the account itself. This is achievable thanks to our custom-created cloud platform, which allows us to run different PHP versions at once. In comparison, the majority of hosting vendors normally support one, in rare cases – two versions.